This is documentation for MapR Version 5.0. You can also refer to MapR documentation for the latest release.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. Download the Ext JS 2.2 library as a zip archive (ext-2.2.zip) from this location.

    Info

    The Ext JS 2.2 library is required only for the Oozie Web UI. Note that a rewrite of the Oozie web UI has been proposed in the Oozie user community.

  2. Copy the Ext JS 2.2 library into the libext directory: 

    Code Block
    languagetext
    cp ext-2.2.zip /opt/mapr/oozie/oozie-<version>/libext
  3. Perform one of the following options based on your preference:

    1. If you want the Oozie Web UI to start whenever Oozie starts or restarts, perform the following steps:
      1. If Oozie is running, shut it down:

        Code Block
        languagetext
        maprcli node services -name oozie -action stop -nodes <space delimited list of nodes>
      2. Run the oozie-setup.sh script, and specify the hadoop version.

        Code Block
        languagetext
        /opt/mapr/oozie/oozie-<version>/bin/oozie-setup.sh -hadoop <version> /opt/mapr/hadoop/hadoop-<version>
    2. If you want to manually start the Web UI when Oozie starts or restarts, perform the following steps:

      1. If Oozie is running, shut it down:

        Code Block
        languagetext
        maprcli node services -name oozie -action stop -nodes <space delimited list of nodes>
      2. Run the oozie-setup.sh script and specify the path to the extjs file.

        Code Block
        languagetext
        cd /opt/mapr/oozie/oozie-<version>
        bin/oozie-setup.sh prepare-war -extjs <path to file>/ext-2.2.zip
  4. Start Oozie.

    Code Block
    languagetext
    maprcli node services -name oozie -action start -nodes <space delimited list of nodes>

...